What are the system requirements?

The minimum system specification to run MAP 2.0 is Internet Explorer 7, Flash 10 and a broadband connection. The system does run on a 512k connection, however we would advise 1mb upwards as an ideal.

Sign up for our newsletter to get the latest news

By submitting this you agree to our Privacy Policy Invalid Input